Good point. On the one hand, do-after-delay is the logical name for it. On the other, I think the name of the Javascript function should be preserved somehow since that way there will be less cognitive dissonance, and there would be one less barrier to entry for new users. How does do-set-timeout sound?
I have to run soon, so I'll add ignore-errors sometime tomorrow.
Thanks, Vladimir
On 6/19/07, John Fremlin john@fremlin.org wrote:
About this
(defjsmacro with-timeout ((timeout) &body body) `(set-timeout (lambda () ,@body) ,timeout))
I wonder if with-timeout is really the best name for it? I mean something like do-after-delay would make more sense.
PS. Here's another one
(defjsmacro ignore-errors (&body body) `(try (progn ,@body) (:catch (e))))
[...]