I agree with renaming Parenscript's package from :js to :parenscript or :ps. Indeed, just :parenscript would be fine. A library and its package should usually have the same name. However, some of the function and macro names that Parenscript now complains are deprecated, I actually prefer to their replacements.
 
For example, the js macro is accurately named. I prefer this:
 
   (js (setf x 1))
 
to this:
 
  (ps (setf x 1))
 
...because "js" reminds me that I'm generating Javascript (not Parenscript). To me it's closer to the meaning. What I especially don't like, though, is this:
 
  (script (setf x 1))
 
... because there are at least two other scripting languages embedded in my Lisp code, and the term "script" could apply to any of them. I need to know at all times which kind of script I'm working with. In this case it's Javascript.
 
Similarly, I much prefer "defjsmacro" to "defscriptmacro". Much clearer and more expressive.
 
There's sort of a philosophical point here. I don't see Parenscript as a separate language. I see it as an interface to Javascript. I don't want an extra mental layer getting in the way, and I certainly don't want to forget that I'm writing Javascript. (I love using macros to build up abstractions in Parenscript - in fact that's a big reason I use PS - but to me that's a separate issue.)
 
Bottom line, I have a moderate preference for "js" names instead of "ps" ones and a strong objection to the generic term "script". What do others think?
 
Daniel